Nulab Inc. Status
Subscribe
to updates
【Backlog】File downloads and viewing are currently unavailable.
Major incident
Backlog
2025/01/09 00:32 UTC
· 1 hour, 46 minutes
Updates
Resolved
Operating normally.
January 9, 2025 · 02:28 UTC
Issue
File downloads and viewing are currently unavailable.
January 9, 2025 · 01:08 UTC
← Back