Nulab Inc. Status
Subscribe
to updates
【Backlog】You may have trouble to access files and add projects right now.
Major incident
Backlog
2023/09/14 04:42 UTC
· 13 minutes
Updates
Resolved
Everything operating normally.
September 14, 2023 · 05:16 UTC
Issue
You may have trouble to access files and add projects right now.
September 14, 2023 · 04:42 UTC
← Back