Nulab Inc. Status
Subscribe
to updates
【Cacoo】Some spaces have trouble dashboard
Major incident
Cacoo
2023/07/03 00:55 UTC
· 9 hours, 59 minutes
Updates
Resolved
【Cacoo】Everything operating normally.
July 3, 2023 · 11:32 UTC
Issue
【Cacoo】Some spaces have trouble dashboard
July 3, 2023 · 05:32 UTC
← Back